Results 1 to 2 of 2

Thread: Zoom to Element Fix

  1. #1

    Zoom to Element Fix

    Using InfoWater, I use the search tool to find and select a specific element (doesn't matter which type). When I click the zoom to element icon, the model zooms to extents and the element will flash. The problem is that when it has zoomed to extents, it is useless.

    Anyone have a fix for this?

  2. #2
    Forum Moderator

    Innovyze Employee



    Innovyze Employee



    Join Date
    May 2015
    Posts
    420
    You probably have an issue with your full extents being zoomed way out. The InfoWater Zoom uses a percentage of full extent, but if your full Extents is way too large the zoom will "appear" to not work.

    To check.

    Try using the model explorer to zoom to an element. Does it zoom way out? If so check the full extents by pressing the Zoom Extents button in ArcGIS (looks like a globe). If your zoom is way far out and your model looks like a few tiny points use this to first fix the zoom extents:

    1) Manually zoom till your view is where you want the fixed extent to zoom to.
    2) Right click on the Bold "LAYERS" in the table of contents and right click and select Properties
    Under the "Data Frame" Tab look in the middle under "Extent used by Full Extent Command" and choose "Other" and press Specify Extent and choose "Current Visible Extent" option. Then hit OK twice to close the windows.
    3) Verify this fixed the full extent by once again pressing the full extent Icon in ArcGIS (looks like a globe). If fixed the view should not change. If it still zoomed out repeat the previous steps until fixed.
    4) Next Adjust your Zoom Percentages used by InfoWater until your zoom is as desired. These are found in the InfoWater menu- Tools -Project Preferences in the "Display Settings" Tab. The Noel Locate Percentage is the % of full extent used to zoom to a point element and the Pipe Locate Zoom Factor is the percentage of full extent used to zoom to a pipe element. The larger the model the smaller the value that will be needed. Many models work pretty well with values between 1 to 0.001. I would start with 0.1 and make it smaller as needed.
    5) Once the zoom extents and percentages are adjusted you should have no issues with any zoom function in the model explorer or in the DB Editor.

    If you need further assistance reply to this thread.

    Patrick Moore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •