Results 1 to 3 of 3

Thread: XPSWMM "Error: failed integration with: SWMM"

  1. #1

    Join Date
    Nov 2017

    XPSWMM "Error: failed integration with: SWMM"

    I am running XP SWMM 17.0 [12.0] and trying to run a previously created and successfully run (last fall) 2D hydraulic model. Without any changes to the model, when trying to run either the runoff or hydraulic block (separately or together), both with the 2D turned off or on, I get an error that states "Error: failed integration with: SWMM". I have tried everything that I can think of and searched for guidance on this error online and in forums to no avail. I have tried running with the 64 bit SWMM method instead of 32 bit. When running the 64 bit, it does not give me the error, but crashes every time I run it. I'm open for anyone's suggestions for how to address this error and get the model up and running again.



  2. #2
    Lloyd -

    Please open a case in the support portal. The issue can occasionally come down to a number of issues regarding computer speed, file path, or computational method. TO see more, check out the knowledge base article here.
    Matthew Anderson, P.E. CFM
    Products Manager

  3. #3

    Innovyze Employee

    Join Date
    May 2018
    This error means that the engine is not launching in an appropriate amount of time, despite having been called by the user interface section of the program. There are a number of possible fixes for this. Here are a few of the more common solutions:

    1) (for XPSWMM 2016 and earlier) Switch over to the 64 bit version of the engine. This can be done by going to Configuration -> Mode Properties -> Methods. XPSWMM 2017 and later use the 64-bit version of the engine by default.

    2) Make sure that you have a simple file path for your project files. Try to avoid special characters, long folder names, long scenario or project names, complicated paths. You can also try moving it to a local drive if the project is saved on a separate server.

    3) Make sure you have full read/write/access privileges for the project folder.

    Usually if the program crashes, that is a separate issue altogether, and it is best to look at the 1D and 2D logs to see if there are clues as to why it crashed. If no clues are present there, if often comes down to one node or link that is the problem. Make a backup of the model and start inactivating sections of the model until it starts working again. By inactivating/reactivating sections, you can usually narrow down where the problem is and the problem becomes more obvious, although this method often takes a bit of work.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts