Results 1 to 2 of 2

Thread: Error message using the Calibrator tool

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Join Date
    Apr 2014
    Posts
    2

    Error message using the Calibrator tool

    Hi, i was working with a extensive model and in many times i ran the static and extended calibration, but in the last try to calibrate the model, the software show me and error and in this time i cant run the calibrator. This is the Error with a red Light:
    > GA: Error 2112: unable to complete hydraulic simulation at given run time
    > Error 2112: unable to complete hydraulic simulation at given run time

    I Have a green light in the extended model, so i dont understand why show me the error an red light in the static calibrator.

    Thank you for any suggestions.

  2. #2
    Forum Moderator

    Innovyze Employee



    Innovyze Employee



    Join Date
    May 2015
    Posts
    420
    Julian,

    It is very difficult to assist you without seeing your model and knowing which "mode" of the calibrator you are using that had the error but unfortunately it looks like the licenses for ENCALI appear to have expired in 2015 which means you may not be not running the latest version of our software and if expired don't have access to technical support and cannot apply product updates. If this is not the case and you do have an up to date Annual Maintenance please reach out to us at support@innovyze.com and mention this post in your email and we will send you a link to upload your model as this is the best way to diagnose a complicated model issue as described.

    What we always first suggest is to verify you are using the latest version of our software, which as of today is InfoWater 12.4 update 2. This can for users with a current InfoCare Annual Maintenance be downloaded form our website at http://www.innovyze.com/updates/. This ensures you are using the latest and greatest version of the software.

    However, to assist other users in the forum, we will attempt to provide at least some basic guidance. But an issue like this is something we would generally need to see your specific model to see what is going on. The calibrator tool is modifying the parameters you specify (Generally c-factors) and running a very large number of runs within the genetic algorithm it uses. If you are getting warning messages like this during a calibrator run it would seem that some parameter you are specifying is creating conditions that would not allow for a run to be completed under those conditions specified and this is why you are seeing the error in the calibrator and not in the EPS runs. I would begin by checking the calibrator tool setup to make sure you are not creating conditions which would not be solvable in the model. From the error, something is keeping the model from running using the parameters set, and if a solution is not able to be found it would give a similar error.

    One last note of use of Calibrator. The calibrator is a great tool if you have pipes in your system that are known to corrode internally like Unlined Cast Iron or Unlined Steel. Since these pipe materials corrode internally it is handy to have a tool setup that can help best fit all of the data you have by adjusting the c-factors for those pipes as they are known to change over time. However, if most of your pipes are cement mortar lined or Concrete, or Plastic, those pipes do not corrode internally and thus would not be expected to have C-factors change over time. For those pipes, it would not generally be appropriate to use the calibrator to adjust pipe c-factors unless the pipes were corroding internally.

    For systems that have very little unlined cast iron and unlined steel pipes modelers usually find model vs field differences are more often associated with connectivity or unexpected closed valves rather than c-factors. Also make sure you are adjusting demands and boundary conditions under all circumstances and not just potentially massaging c-factors to address differences in boundary conditions and or connectivity issues.

    Here are links to a few other posts on the forum regarding calibration that may be of assistance to you or other forum users:

    As discussed, Hereare some threads on the User forums that may be useful to you:




    Patrick Moore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •