View Full Version : Disconnected nodes and closed reservoir

December 15, 2016, 05:58 PM
When I tried to run my model I got the message that a selection of disconnected nodes was created
*Thus, I went to Domain Manager ->Selection Set (Disconnected_Nodes) -> Add
*Disconnected nodes appear in Red.
*I corrected and removed the nodes. I run the simulation, but I still get the message of **A special selection of 'Disconnected _Nodes' has been created for all disconnected nodes**
*I go back to Domain Manager ->Selection Set (Disconnected_Nodes) -> Add
*But there are no red nodes

How can I find and fix my disconnected nodes?

Besides, I get the message
0:00:00: Reservoir RES9002 is closed
I am running steady state. How can I fix the closed reservoir?

December 15, 2016, 06:25 PM
I fixed it.
Just changed the size of domain symbol
The closed reservoir was automatically fixed

December 21, 2016, 05:03 PM
How did you change the domain symbol. I have similar warnings when I run my model

December 25, 2016, 11:11 PM
Just right click on the symbol in the table of contents, like normal GIS

December 27, 2016, 10:10 AM
I changed and increased the size of the "Reservoir" symbol but keep getting the same error message of a closed reservoir. Any tips?

Patrick Moore
December 29, 2016, 08:39 AM
NOTE: If you get a "Disconnected Node" error, but don't see any junctions look for pumps and valves which are also considered "Node" elements. In InfoWater pumps and valves are point elements but in EPANET are line elements. To do this InfoWater adds two hidden nodes on the suction and discharge side of the pump/valve that you can't see but are included in the EPANET model run for analysis. If either of these hidden nodes shows as "disconnected" InfoWater will highlight the pump/valve in the selection set.

This often occurs when a check valve is used downstream of a pump (unnecessary as model pumps have a built in check valve) or there is a second pipe closed and the valve is closed. If you remove the check valve and or the second closed pipe generally these will no longer show as disconnected. NOTE: for the element to be disconnected it has no path back to a known tank or reservoir and thus has no reference HGL point for the model to use to solve.

If you are getting a closed reservoir error check the full status run report ( in the run manager -> Standard tab -> Report options --> Set the Status report to full and check generate warning messages). I believe if you are getting this error the hydraulic engine is having difficulty solving and is trying different things to get a solution. This is generally not something that should be a display issue. The run report will often let you know what is occurring. If it says "max trials reached system may be unstable" that can be a clue. If you can post the last few iterations in the run report, that generally will give a sense of what the issue is.

Patrick Moore