Results 1 to 2 of 2

Thread: Copy model to another PC

  1. #1
    Member
    Join Date
    Dec 2016
    Posts
    53

    Copy model to another PC

    I have some water distribution models in InfoWater
    I want to copy them to another computer. I copied the whole:
    xxx.out folder
    xxx.IWDB folder
    xxx.mxd map

    When I try to open them in the new computer it asks me for a database connection. I can open the mxd and visualize the netwrok. However, when I try to launch InfoWater (red arrow) then I get asked about the database connection. Then I get project initialization failed

    The Data spource points to: xxx.IWDB folder -> Map folder -> MAp.mdb -> NETWORK -> the respective element (pipe nodes ...)
    How can I copy the InfoWater project?
    Last edited by Vladyman; January 10, 2018 at 12:00 AM.

  2. #2
    Forum Moderator

    Innovyze Employee



    Join Date
    May 2015
    Posts
    340
    Vladimir,

    If you want to copy a model from one location to another you can do it one of two ways.

    1) Method 1: Open the model , initialize and do a save as and save the model to a new location. This method will preserve any links to background layer files that you are using which is an advantage. This method will also copy over the old model .OUT folder to a new .out folder for the saved location. This is often the easiest way to save a model to a new location if you have access to the new model save location. NOTE: Make sure you Initialize the model before doing the "save as" or you will not save the model database folder.

    2) Method 2. Save and close your model you wish to copy to a new location. (important) You only want to use this method on a model that is currently closed. Copy over the modelname.Mxd file and the modelname.IWDB folder. (Copying the .OUT folder is optional as it can be very large and will be recreated when you initialize the model if it is missing) If you are sending the model to someone else it is often ideal to zip the .MXD file and .IWDB folders into a single zip file so that they unzip in the expected locations. (The modelname.MXD file and the modelname.IWDB folder need to be in the same directory to work properly). Simply unzip or save the modelname.MXD file and the modelname.IWDB folder in the new location and you should be able to open and initialize the new model. Note that this method may cause background layer files to no longer be connected and show with a Red exclamation mark in the table of contents. They can be reconnected, but will only do so with input from the user. However all model database files and model layers should open and initialize without issue.


    If you get an error when trying to move a model check first to see if you can open and initialize the original model. If there were issues with the original model .IWDB folder these would occur. You also want to make sure that if you zipped the .IWDB folder separately from the .MXD file it may have created a dummy folder when unzipped that you need to either move up so that when you open the >IWDB folder in the same directory as the .MXD file you see the model database folders instead of a single .IWDB folder. This is the advantage of always zipping both together as a single file.


    It sounds like most likely you may have either had an issue with the original model or don't have the files of the .IWDB folder in the correct "directory" the model expects them. Without seeing it directly or having more data it is hard to say exactly, but this would be our best guess based on what it is telling you.

    If you find you still need assistance please reply to this thread or contact us at support@Innovyze.com for more detailed assistance.

    Patrick Moore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •