Results 1 to 2 of 2

Thread: Epanet Network gives different results on different computers

  1. #1

    Join Date
    Nov 2017
    Posts
    1

    Epanet Network gives different results on different computers

    Hello
    I created an Epanet network while at office using the work computer and I successfully run it. I then saved the network on a flash drive for further work at home. However, when I opened the network using my home computer, the network failed to successfully run and kept giving the error message, "System unbalanced".
    Without altering it, I opened the same network on the flash drive at work the following day and it run successfully.
    What could be causing this? I am starting to wonder if the network I modeled is actually okay.

    Thank you

  2. #2
    Forum Moderator

    Innovyze Employee



    Join Date
    May 2015
    Posts
    295
    Justin,

    We apologize, but this is a forum for users of Innovyze software products and is not intended for direct EPANET users per say.

    However, if you are getting System Unbalanced errors there is likely something causing model instability such as two or more PRV's fighting each other for control.

    Make sure you are using a "Full" status report and If you were in Innovyze software you would also want to make sure it will generate warning messages, as Warning messages and the full status report tell you if something is occurring.

    You should definitely investigate as there likely is an underlying issue. Search the full status report for details on what is occurring. Usually seeing the same item turn active to open and open to close and closed to open over and over indicates elements fighting for control which often leads to system unbalanced.

    Under your hydraulic options you can try the following which may help for convergence. There are a few other things you can do in InfoWater that you can't do in EPANET, but these settings you can change in EPANET:

    Max Trials : Set to 200
    IF Unbalanced - Continue
    Status Report: Full
    DAMPLIMIT: Set to 10X your accuracy. (Eg: if using 0.001 accuracy set to 0.01)


    If you were in InfoWater we would recommend the following options to address model instability impacting the ability of the model to converge:

    These would be set in the software Simulation Options (Can reach from the run manager Standard Tab)
    (click if need larger images)
    Simulation Options - For Convergence.jpg

    (click if need larger image)
    Simulation Options - Advanced.jpg

    These options alone generally can resolve most model convergence issues. If convergence issues persist there is a good chance that one or more setpoints need to be changed to resolve such as expanding the net HGL setpoints between fighting PRV's by changing the settings and or the elevation of the valve or downstream junction.

    Hope these at least help you with a few things that also may help our software users.

    Patrick Moore

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •